not 3.6 compatible? Bewertet mit 2 von 5 Sternen

refused to install on FF 3.6