Bewertet mit 1 von 5 Sternen

It says that it's compatible with FF3. It's not.
Update, please?