Bewertet mit 5 von 5 Sternen

Hello Friends,

This Abduction version is not compitable with Firefox 37 and above, We have updated the code of this outdated addon and fixed it to work with latest firefox version.

Download latest version here - https://addons.mozilla.org/en-US/firefox/addon/abduction-fixed/

Dieser Benutzer hat eine ältere Bewertung zu diesem Add-on.