Tony Mechelynck

O mně

Informace o vývojáři
Jméno Tony Mechelynck
Umístění Brussels, Belgium
Zaměstnání retired
Domovská stránka
Zaregistrován(a) od March 5, 2007
Počet vyvíjených doplňků 1 doplněk
Průměrné hodnocení doplňků vývojáře Ohodnoceno 4 z 5 hvězdiček

Doplňky, které jsem vytvořili

Nightly Tester Tools

Useful tools for the nightly tester.

Ohodnoceno 4 z 5 hvězdiček (191)
36 320 uživatelů

Mé recenze

Keyword Search

Just the search I needed Ohodnoceno 5 z 5 hvězdiček

Thanks to this extension I don't need to change any settings to use the English Wikipedia when typing in the URL bar, the French Wikipedia in the Search bar and the aw<s>esome</s>ful bar, and DuckDuckGo on right-click.

I love it.

Tento uživatel má jednu dřívější recenzi tohoto doplňku.

Словарь синонимовъ RU

Word-ending hard sign: Pre-1917 orthography? Ohodnoceno 3 z 5 hvězdiček

Once upon a time, every single Russian word had to end with either a vowel, a soft sign (ь, мягкий знак) or a hard sign (ъ, твёрдый знак). This was a leftover from when the latter two were pronounced as very short instances of the vowels i and u respectively, and no consonant could end a word; but since in the meantime they had become diacritical signs telling the reader whether the preceding consonant was soft of hard (and word-ending consonants had reappeared by virtue of the muting or almost-muting of these extra-short vowels), it was decided (as part of the 1917 reform IIUC, when my late grandfather was a teenager) to remove the hard sign in that position. It only remains where a prefix ending in a hard consonant is followed by a yod, e.g. in the verb съесть (to eat, perfective, ← с + есть).

I wonder if this dictionary also uses other letters long disappeared from current orthography. For instance, does it spell "мѣждународный" with ѣ, as under the Czars? (In modern spelling, the synonym pair would be международный = интернациональный, "international".)

PDF Viewer(discontinued)

Doesn't always work Ohodnoceno 3 z 5 hvězdiček

Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141110003001 c-c:8ab46a67ce9e m-c:d380166816dd

It doesn't always work, I don't know why; I suppose it's something in the PDF file which makes it never stop "loading" with a rotating throbber in the middle of a blank (or almost blank) page. But when I have this problem I can invoke the standalone Acrobat Reader on the same file by means of the "Download" button near top right (which has options "Save to disk" and "Open in acroread").

Remember Passwords

Ohodnoceno 3 z 5 hvězdiček

In SeaMonkey 2.29 (based on Toolkit v32) and later, this extension "hides" all saved passwords. Getting mail becomes impossible because the saved password is not seen and a new one is not asked for.
Downgrading makes the passwords reappear. Also disabling the extension which IIUC is unncessary in Toolkit v30 (SeaMonkey 2.27) and later.


Ohodnoceno 5 z 5 hvězdiček

Bugmail 2.0 from
After updating from SeaMonkey 2.27a1 to 2.31a1 the extension stops working (no more bugmail display when viewing a bugmail from I'll try Colin Guthrie's version.
Here are my UA strings, build IDs, and CSIDs:
2.27a1: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 SeaMonkey/2.27a1 ID:20140214003001 c-c:1ce77c2f9bd0 m-c:d275eebfae04
2.31a1: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 SeaMonkey/2.31a1 ID:20140723133406 c-c:acb745a4d796 m-c:d0f6259e8446

-- AMO gives contrary messages (about 1.6.1): "Works with SeaMonkey 2.0a1and later" and "Not available for SeaMonkey 2.31a1".
-- "Please do not post bug reports in reviews, see the support section"... of which there is none.

This was an excellent add-on… while it worked.

Tento uživatel má 2 předchozí recenze tohoto doplňku.


Wow! Ohodnoceno 5 z 5 hvězdiček

Even if it had been only a "styling-only" add-on, having such a nice page with the application logo (SeaMonkey, in my case) rather than Mozilla's bland XUL page would have been a huge bonus; but on the "Page not in cache" page I noticed a "Search" button which IIRC wasn't present in Mozilla's XUL. I didn't use it (I had a link to the desired page on another tab) but I'll have to find out exactly what it does.

P.S. And the application-specific add-on manager logo is a nice touch. Already too many of my SeaMonkey extensions have descriptions saying “for Firefox” or “for Thunderbird”.

Tato recenze je pro předchozí verzi doplňku (1.3.20130808.1-signed). 

Lightweight Themes Preview for SeaMonkey

When enabled, disables hovering over "Apply Theme" submenu Ohodnoceno 1 z 5 hvězdiček

Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 SeaMonkey/2.24a1 ID:20130919003001 c-c:1ea1fc3586db m-c:803189f35921

Lightweight Theme Preview for SeaMonkey 0.1

When this extension is enabled, moving the mouse from "Apply Theme ▶" in the View menu to the submenu thus opened, immediately closes both the View menu and the submenu.

If there is a support forum for this extension, I haven't found it, sorry.

Lightweight Themes Manager

Ohodnoceno 5 z 5 hvězdiček

When many lightweight themes are installed, this add-on makes managing them extremely easy, including (but probably not limited to):
-- telling lightweight themes and complete themes apart from each other (in the Add-on Manager they appear interspersed in a single list; this extension opens a page listing only lightweight themes);
-- checking how a lightweight theme other than the current one would look like if it were enabled (by hovering the mouse over the thumbnail);
-- finding which lightweight themes were installed from an obsolete URL (such as and need to be refreshed if they are to be used again in the future. (These "obsolete" add-ons are shown in the LWTM without a thumbnail.)
---- WARNING: Reinstalling the same lightweight theme, but from a working URL (such as, which can be done by means of the link in the LWTM page, won't make the obsolete entry disappear; and AFAICT there is no [_Uninstall_] button for lightweight themes. AFAIK the only way to uninstall a lightweight theme consists of removing the corresponding {...} entry, with one (but not both) of the separating commas around it, in the value of the preference lightweightThemes.usedThemes in about:config. Since that value can be extremely long, especially if many lightweight themes are installed, I recommend to do this as follows:

1. In about:config, find the preference lightweightThemes.usedThemes, right click it, and select "Copy Value";
2. Paste the value into your favourite text editor and edit it there;
3. Copy the new value (as it appears in your editor) to the clipboard;
4. in about:config, double-click lightweightThemes.usedThemes (the old value will appear, selected, in an input box in a popup) then click Ctrl+V (to paste the new value which you copied at step 3) then click the [_OK_] button at the bottom of the popup. If you then refresh about:addons or the LWTM (or both) you should notice that the unwanted entry has disappeared.

P.S. Of course, in Thunderbird, about:config is the "Config Editor" which can be opened by means of a button in the "Advanced" preferences.

Tato recenze je pro předchozí verzi doplňku (0.1a10.1-signed). 

Zippy Extension Packager

Where is this menuitem? Ohodnoceno 4 z 5 hvězdiček

Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 SeaMonkey/2.24a1 ID:20130919003001 c-c:1ea1fc3586db m-c:803189f35921

Zippy Extension Packager 17

The "Create XPI" menuitem is not to be found in the context menu for extensions in the "Recent Updates" tab of the Add-ons Manager. In the "Extensions" tab it is present, at the very bottom under a separator.

Tato recenze je pro předchozí verzi doplňku (17.1-signed). 

Keyword Search

Ah, great! Ohodnoceno 5 z 5 hvězdiček

It used to be that I could search with Wikipedia(en) in the URL bar and with either Wikipedia(fr) or the Mozillazine Knowledge Base in the Search bar but now (without this add-on) it seems that changing the one changes the other too.

I hope that it will work with SeaMonkey 2.23, currently «Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1» ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5 even though when I try to install it AMO warns me that «I need Firefox 10.0 or higher» (then installs it if I okay the warning).

Edit: To make it work, you have to enter your search keyword(s) in the URL bar _and hit Enter_. Using the up-down arrows to select the search widget for the URL bar, or (of course) searching with the search bar, will get you your current search engine as set in the Search bar, in SeaMonkey's "Edit → Preferences → Browser → Internet Search", and in the about:config pref “”.

Tato recenze je pro předchozí verzi doplňku ( 


Ohodnoceno 5 z 5 hvězdiček

Nice! (And reassuring: of 70 enabled extensions, the biggest ones are Adblock Plus, ChatZilla and "SeaMonkey", all the rest is below 3 MB apiece, total 135 MB).

Tato recenze je pro předchozí verzi doplňku (6.1-signed). 

QuickFolders (Tabbed Folders)

Great and well-maintained! Ohodnoceno 5 z 5 hvězdiček

Not only this is a great add-on to enhance the mail windows, its author is actively maintaining it for both Thunderbird and SeaMonkey, diligently reading bug reports and fixing problems found by users of both mailers on all three of Windows, Linux and Mac, and on 32- and 64-bit processors. :-) :-) :-)

Tato recenze je pro předchozí verzi doplňku (3.10). 

Config Descriptions

Ohodnoceno 5 z 5 hvězdiček

A must-have for serious hackers who are not afraid of “voiding their warranty” by setting preferences yet still prefer to know what they are doing. :-)

Tabs Menu

For me this is a must Ohodnoceno 5 z 5 hvězdiček

This extension (which works even in SeaMonkey 2.8a1 if I override compatibility checking) allows me to jump easily and fast to any of my about 200 open tabs (at the moment), in conjunction with the following userChrome.css rules to remove the all-tabs button on the tab bar (where real estate is in high demand) and replace long menus' scrollbuttons by a scrollbar (so I can scroll them faster):

* hide all-tabs-button on tab bar in favour of Tabs Menu extension on menubar
* Gecko 2, 2010-12-29 and later
tabbrowser:not(#tabmail) .tabs-alltabs-button
{ display: none !important
* give the menus a scrollbar when they are too high to be
* displayed in full
menupopup scrollbox, #contentAreaContextMenu scrollbox
{ overflow-y: auto !important
* eliminate scroll buttons at top and bottom of the menus
menupopup autorepeatbutton, #contentAreaContextMenu autorepeatbutton
{ display: none !important

I love it.

Display mailing list header

Works with the latest nightlies Ohodnoceno 5 z 5 hvězdiček

This add-on works for me (with a compatibility override) even in SeaMonkey 2.6a1 without Mnenhy or Enigmail, even though it only advertises support for the long-gone SeaMonkey 1.0 and only with either of these other extensions enabled.


Ohodnoceno 1 z 5 hvězdiček

Has only been «preliminarily reviewed» and all the versions it supports are already obsolete! And no picture, except of the least-used window type! Ah la la :-(

Tato recenze je pro předchozí verzi doplňku (0.3). 

Nightly Tester Tools

Ohodnoceno 5 z 5 hvězdiček

WildcatRay: yes it should (blush). I've submitted a further update.

Tato recenze je pro předchozí verzi doplňku ( 

Ohodnoceno 1 z 5 hvězdiček

«What do I think?» I think that this add-on ought to have a name.

SeaMonkey Debug and QA UI

Ohodnoceno 5 z 5 hvězdiček


Provider for Google Calendar

Ohodnoceno 5 z 5 hvězdiček

@cimenta: For use with nightly builds of Lightning / Sunbird, you must use the version of gdata-provider.xpi found on FTP in the same directory as the Lightning nightly (gdata-provider 0.6pre for current nightlies of Sunbird/Lightning 1.0pre), not the one found here.

Tato recenze je pro předchozí verzi doplňku (0.5.5).