XFCE not Supported Ohodnoceno 2 z 5 hvězdiček

The Download links says that it works for linux, but does not seems to work on LinuxMint 15 [XFCE].
Or May be im not able to use it, please help. I used it under windows, and want it here too.