Ohodnoceno 4 z 5 hvězdiček

Is it really not compatible anymore with Firefox 3.6.* ?