i found a workaround for using kwallet with new version of sync authentication Ohodnoceno 1 z 5 hvězdiček

in FF
disconnect from sync service
unactivate kwallet plugin
restart FF

check that kwallet plugin is well unactivated

connect to sync service
go to FF password manager
copy somewhere the password of "Chrome://FirefoxAccounts (Firefox Accounts credentials)"
activate kwallet plugin

in kwallet manager replace the password of "Chrome://FirefoxAccounts" by the password you copied somewhere

restart FF

enjoy !

my explication : passwords(tokens) delivered with or without kwallet manager activated are different

with kwallet activated
{"version":1,"accountData":{"sessionTokenContext":"fx_desktop_v1","unwrapBKey":"d92...fe7","keyFetchToken":"6vg...3eb","customizeSync":false}}

with kwallet unactivated
{"version":1,"accountData":{"sessionTokenContext":"fx_desktop_v1","customizeSync":false,"kA":"65...09","kB":"01...46"}}

Tento doplněk má 8 předchozích recenzí tohoto doplňku.

Breaks sync Ohodnoceno 3 z 5 hvězdiček

Breaks new sync (need to login to sync after every restart).

Excelente Extensión para los usuarios de KDE Ohodnoceno 5 z 5 hvězdiček

Excelente extensión. Siempre tuve desconfianza de que el navegador guardara las contraseñas, así que como usuario de KDE me fijo perfecta. Solo faltaría indicar que luego de instalarse las contraseñas deben cargarse nuevamente, pero no es nada grave.
Si la cartera no está abierta las contraseñas no pueden verse desde el navegador.
Funciona muy bien
GRACIAS !!

Ohodnoceno 5 z 5 hvězdiček

The fix by jaanvajakas worked for me on Fedora 20, KDE 4.14, thanks a lot. I just had to figure out where to add the lines. The last few lines of my file are now like this:

get isLoggedIn() {
return true;
},

init: function () {
this.initialize();
},
};

const NSGetFactory = XPCOMUtils.generateNSGetFactory([KDEWalletStorage]);

Tento uživatel má jednu dřívější recenzi tohoto doplňku.

Ohodnoceno 3 z 5 hvězdiček

kubuntu 14.04, thunderbird 31.2, KDE Wallet password integration 2.4. Does not work. Im so sad about it.

not working in firefox 34 Ohodnoceno 1 z 5 hvězdiček

your fix does not work for me on firefox 34, this is what I see when it crashes:

unnamed app(26539)/kdevplatform KDEWallet_GetStorageVersion: Start
unnamed app(26539)/kdevplatform checkWallet: Start
unnamed app(26539)/kdeui (Wallet) KWallet::Wallet::openWallet: Pass a valid window to KWallet::Wallet::openWallet().
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QEventLoop: Cannot be used without QApplication

Fix for version 2.4 in Thunderbird 31 Ohodnoceno 4 z 5 hvězdiček

To make it work in Thunderbird 31.2.0, I had to add the lines

init: function () {
this.initialize();
},

to the file .thunderbird/<profile name>/extensions/kwallet@guillermo.molina/components/KDEWalletStorage.js in my home directory.

Does not work in thunderbird-31 anymore since upgrade to version 2.4 Ohodnoceno 4 z 5 hvězdiček

Could you please have a look, why it does not work in thunderbird 31 with version 2.4 anymore?

This is a great addon! I would really miss it!

No funciona en FF 33 y "esconde" las contraseñas almacenadas en el perfil. Ohodnoceno 1 z 5 hvězdiček

No funciona con Firefox 33 y además borra las contraseñas almacenadas, así que recomiendo que nadie la instale hasta que salga una versión compatible con FF 33 y superiores o perderéis todas vuestra contraseñas si no os las sabéis de memoria.


Matizo:
Tras reiniciar Firefox (el complemento había sido desactivado, pero Firefox llevaba varios días sin ser reiniciado, por lo que la desactivación no se había hecho efectiva ya que este complemento requiere el reinicio del programa para que se apliquen estos cambios) mis contraseñas han vuelto. Así que no es cierto que el complemento borre las contraseñas, simplemente no muestra ninguna, ni siquiera las que ya tenemos en Kwallet. Esto evidentemente no es tan grave como hubiera sido la eliminación de las contraseñas, pero el usuario que deje el complemento instalado o activo en espera de que salga una actualización que funcione, simplemente va a ver que sus contraseñas no están en Preferencias/Seguridad/Contraseñas Guardadas ni por supuestos se escriben automáticamente. Bien, pese al susto inicial, lo cierto es que las contraseñas siguen ahí, sólo hay que desactivar o desinstalar este complemento y reiniciar Firefox. La contraseñas reaparecerán.
No obstante, de momento, a 5-11-14, el complemento es desaconsejable por no funcionar y por "esconder" las contraseñas almacenadas.


P.S: Te respondo, Guillermo.
Me creo que soy un usuario que ha sufrido las consecuencias de este complemento en FF33 (eliminación de todas y cada una de las contraseñas que mi navegador tenía almacenadas), nada más y nada menos; y que como corresponde a este sitio, hace una valoración basada en su experiencia (mala) en el uso de esta extensión.
Y sí, como esto es una comunidad donde cada cual intenta contribuir como puede -los informáticos programando, los usuarios comentando- recomiendo a los que me lean que no la usen si no quieren ver volar sus contraseñas. Sería un HP si sabiendo que algo causa perjuicios me lo callase, no crees?

Y a ti también te recomendaría algo: menos soberbia y más respeto por los usuarios, que no hemos venido aquí para atacarte ni escribir infundios sobre tu trabajo generosamente donado a la comunidad, sino simplemente a decir si un complemento funciona bien o no.

Tato recenze je pro předchozí verzi doplňku (2.2). 

Ohodnoceno 5 z 5 hvězdiček

Does not work anymore with FF32 :/

Tato recenze je pro předchozí verzi doplňku (2.2).  Tento uživatel má jednu dřívější recenzi tohoto doplňku.

FF32 is incompatible Ohodnoceno 5 z 5 hvězdiček

Yes, they did something with password management in FF32, so dont upgrade or disable addon...

Tato recenze je pro předchozí verzi doplňku (2.2). 

KDE Wallet password integration stopped working with FF32 Ohodnoceno 3 z 5 hvězdiček

Since I upgraded to FF32 KDE Wallet password integration stopped working :.-(

Tato recenze je pro předchozí verzi doplňku (2.2). 

Ohodnoceno 5 z 5 hvězdiček

The crashes for FF25 went away after setting javascript.options.baselinejit.* = false in about:config, as suggested. However they came back in FF30. It turns out there was a new baselinejit added. Setting that to false seems to solve this.

Tato recenze je pro předchozí verzi doplňku (2.2). 

Crash bug solved by compiling from the sources (in preply to comment) Ohodnoceno 5 z 5 hvězdiček

Crashes are still threre for me with 2.2 and 2.3 (homepage of developer).
However, i was able to get rid of them by compiling the plugin myself form svn. The crucial step seems to be, that you build libkdewallet.so so please first build this liib with the provided cmake file and pack the plugin afterwards.

I do not need to disable any jit-compiler in FF or any other special settings.

&gt; von Guillermo Molina (Entwickler) am August 5, 2014 . Permanentlink · Übersetzen

&gt; I do compile each of the libraries before packing, If you only do that and it works for you it's just luck. We have an open bug on moz-dev about this, the problem is still pointing to a bug in the new JIT compiler, or at least, some incompatibility with it and foreign libraries."

In reply to your comment:
- with "you" i didn't mean the developer, i was guessing that you are building the library before packing. It was ment as a tip for peaple wich want to fix the bug for themselves.
- a littel background information:
-&gt; i am using gentoo and compiled firefox from the sources on my own. Maybe there is a incompatibility beween my compiler / optimization settings and your ones? i use the gcc-4.7.3 with CXXFLAGS=CFLAGS="-march=native -O2 -pipe -ggdb" and kde 4.13.3
-&gt; the recompilation solved teh bug for 5 diffrernt machines (all with gentoo). So the fix seem reliable ti me.

Tato recenze je pro předchozí verzi doplňku (2.2).  Tento uživatel má jednu dřívější recenzi tohoto doplňku.

Excellent Support Ohodnoceno 5 z 5 hvězdiček

Disabling javascript.options.baselinejit.* in about:config to false resolved the issue I reported in a previous review. Thank you for your great support, Guillermo.

Tato recenze je pro předchozí verzi doplňku (2.2).  Tento doplněk má 2 předchozí recenze tohoto doplňku.

A good work Ohodnoceno 5 z 5 hvězdiček

Simple and brilliant. The author also supports on http://kde-apps.org/content/show.php?content=116886 and responds to questions and comments.

Tato recenze je pro předchozí verzi doplňku (2.2). 

2.2 Still Crashes Ohodnoceno 5 z 5 hvězdiček

I really like this add-on but I had to disable it after the FF26 upgrade. However, the 2.2 version worked once I disabled baselinejit option per Guillermo's recommendation (below).

Tato recenze je pro předchozí verzi doplňku (2.2). 

It seems that the crashes experienced by the users are related to the new Javascript JIT Compiler Called ION Baseline. Disabling it seems to solve the problem. You can disable it by setting javascript.options.baselinejit.* in about:config to false

Crashes with Firefox 26 Ohodnoceno 4 z 5 hvězdiček

It has been working for me too, until upgraded to Firefox 26. Solution provided by tbali didn't work for me (Kubuntu 13.10 AMD64).

Tato recenze je pro předchozí verzi doplňku (2.1). 

Ohodnoceno 5 z 5 hvězdiček

I like this addon! But after upgrade to FF 26, it crash almost every 2 minutes.
Could you try to fix it, please?

Tato recenze je pro předchozí verzi doplňku (2.1). 

Thnaks tbali Ohodnoceno 5 z 5 hvězdiček

Thnaks tbali editingKDEWalletStorage.js and adding:
get isLoggedIn() {
return true;
}
that fixed it for me.
Back working again.

I discovered google chrome also can use kde wallet now but uses a "pickel" utf16 binary format it would be cool to hack chrome to work like this extenion and allow it to use the shared folder.
Then you could have konqueror, FF and chrome remember all your passwords in one spot.

Tato recenze je pro předchozí verzi doplňku (2.1).  Tento uživatel má jednu dřívější recenzi tohoto doplňku.