Not compatible with latest verson... Rated 1 out of 5 stars

This add-on is not compatible with the latest version of Thunderbird 8.0 Please update.