Historique de version de Scriptish

11 versions

Méfiez-vous des anciennes versions !

Ces versions sont affichées pour informations et à titre d'essais. Vous devriez toujours utiliser la dernière version d'un module.

Version 0.1.11 202.2 KB Fonctionne avec Firefox 21.0 et supérieures, SeaMonkey 2.18 et supérieures

* toolbar button icon fix

Version 0.1.10 202.1 KB Fonctionne avec Firefox 21.0 et supérieures, SeaMonkey 2.18 et supérieures

Version 0.1.8 235.5 KB Fonctionne avec Firefox 4.0 et supérieures, SeaMonkey 2.1 et supérieures

  • No longer supporting the old Fennec. Native Fennec support is coming!
  • Links changed to the Github issues tracker
  • Updates to support Firefox 16+ (GM_xmlhttpRequest, GM_log, etc.)
  • Opt-in synchronization of Scriptish preferences (via Firefox Sync)
  • Doing additional cleanup of resources (zombie compartments)
  • Userscripts created via "New User Script" will now be created as UTF-8. This fixes non-ASCII characters not showing up properly in a newly-created userscript.
  • Added onprogress support for GM_xmlhttpRequest
  • Added the BaseURL argument to GM_safeHTMLParser
  • Localization updates
  • Various minor bug fixes

https://github.com/scriptish/scriptish/compare/v0.1.7...v0.1.8

Version 0.1.7 226.3 KB Fonctionne avec Firefox 4.0 et supérieures, SeaMonkey 2.1 et supérieures

  • Bug fixes for Nightly versions of Firefox (Screen shot, Scratchpad, and Error Console related issues)
  • Using sandbox names now.

https://github.com/scriptish/scriptish/compare/v0.1.6...v0.1.7

Version 0.1.5 220.2 KB Fonctionne avec Firefox 4.0 et supérieures, SeaMonkey 2.1 et supérieures

  • Supporting Firefox for mobile (a.k.a. Fennec) (#164)
  • Web developers can no longer detect Scriptish by changing the location of a window (#469)
  • The "Show Script Source" link will now reuse the original ".user.js" source tab, rather than creating a new one (#494)
  • The Scratchpad "Save As User Script" command is now compatible with the new Orion editor (#495)
  • If available, users will be prompted to use Scratchpad as the user script editor. This can be changed through Scriptish Options (#479, #497)
  • Users will now be prompted for a new editor when extensions.scriptish.editor is invalid (previously threw an error) (#485)
  • Added the extensions.scriptish.config.prettyPrint.enabled preference (#473)
  • Fixed a bug with the user includes/excludes dialog (#481)
  • Added a GM_notification fallback for OSX when Growl is not installed (#484)
  • The metadata key @noframes is no longer ignored if a value is set (#496)
  • Now really adding "zh-TW" (previously omitted from chrome.manifest)

  • https://github.com/scriptish/scriptish/compare/v0.1.4...v0.1.5

    Version 0.1.4 173.1 KB Fonctionne avec Firefox 4.0 et supérieures, SeaMonkey 2.1 et supérieures

    • Fixed bugs where user scripts did not appear in the Add-ons Manager (#411, #413)
    • Added support for install user scripts through the Add-ons Manager (#421)
    • User scripts with updates now appear in the Add-on Manager's "Available Updates" section (#317)
    • Added "zh-CN" (Simplified Chinese) and "zh-TW" (Traditional Chinese) translations
    • Now plays well with AutoPager (#281)
    • The Scriptish icon now displays a badge showing the number of user scripts running (#436)
    • A user script's "Automatic Updates" preference (set through the Add-ons Manager) is now persisted across updates
    • Made the "no scripts" text in the toolbar button menu more descriptive (#349)
    • Implemented @contributionURL, @contributionAmount, and @developer (#215, #221)
    • Added the extensions.scriptish.optimizingRegexpMerge preference to control optimization of RegExps used in Scriptish. Refer to Manual: Preferences for more details. (#386)
    • Now only logging Scriptish messages if the "Log non-critical extension messages to the Error Console" option is enabled (#440)
    • Full support for the Web Console API (console.log, etc.)
    • GM_log will now log to both the Web and Error consoles
    • GM_openInTab now respects the browser.tabs.insertRelatedAfterCurrent preference (#423)
    • Cookies are now passed to the source website during user script installations and updates (#445)
    • Improved efficiency through lazy loading of Scriptish internals and GM_* API functions
    • Improved performance by only parsing a user script's header when metadata is needed
    • Improved Scriptish's method to write files
    • Added GM_xpath (#416)
    • The method property of the object passed to GM_xmlhttpRequest is now optional, and defaults to "GET".
    • Implemented a temporary fix for cases where alert() does not work. See bug 647727. (#422)
    • GM_setClipboard now supports type html (#462)
    • No longer including the test suite in builds released to AMO (#443)
    • Improved popup notification behavior (#391)
    • Consistent with other add-on types, disabled user scripts no longer display an Options button in the Add-ons Manager (#434)
    • Various improvements to the "New User Script" window
    • Various improvements to the "Scriptish Options" windows (#432, #439, and more)
    • Various additions and improvements to existing localizations

    https://github.com/scriptish/scriptish/compare/v0.1.3...v0.1.4

    Version 0.1 96.3 KB Fonctionne avec Firefox 4.0b5pre et supérieures, SeaMonkey 2.1a3 - 2.1b3

    - Adding per script option to disable script defined @include and @match (#193)
    - Parsing author name and website url from @author (#38)
    - Implemented GM_unregisterMenuCommand and GM_generateUUID
    - Implemented @priority, @domain, @icon64, and @supportURL
    - Implemented a blocklist
    - SSL certs are checked when updating scripts, this also applies for redirects that may occur.
    - Fetching review data from userscripts.org
    - New ignoreCache argument for GM_xmlhttpRequest
    - bug fixes

    https://github.com/erikvold/scriptish/compare/v0.1b9...v0.1

    Version 0.1b9 95.2 KB Fonctionne avec Firefox 4.0b5pre et supérieures, SeaMonkey 2.1a3 - 2.1b3

    Adding <em:name>Scriptish</em:name> to <em:localized> in the install.rdf as per Archaeopteryx's request.

    Version 0.1b7 92.2 KB Fonctionne avec Firefox 4.0b5pre et supérieures, SeaMonkey 2.1a3 - 2.1b2