Supposedly recently updated Noté 1 sur 5 étoiles

Doesn't work for me. I have a normal reddit account, no mod stuff, no RES or any other addons.

Noté 1 sur 5 étoiles

No longer functions at all and requires a restart to both install and get rid of. Irritating.

Bug: live is not a function Noté 1 sur 5 étoiles

I get this message message

[JavaScript Application]

Error: $(...).live is not a function


There's no way to contact the author, that is why I post the bug here.

This user added a possible bug fix - https://addons.mozilla.org/en-US/firefox/addon/reddit-reveal/reviews/592708/

Noté 1 sur 5 étoiles

Doesn't work on 35.0

Stopped working with latest Firefox Noté 1 sur 5 étoiles

Doesn't work at all on FF 34.0.5

Noté 5 sur 5 étoiles

Re: "Error: $(...).live is not a function"

I believe I have solved it:

1. Unzip the extension {2a43f346-13de-4aad-adeb-00b61e5bcde3}.xpi to a folder

2. find the file "redditreveal.js"

3. Change the following lines (old line is commented)

a:

// $(".button").live("click", function(ev) {
$("body").on("click", ".button", function(ev) {

b:

// $(".author").live("mouseover", function (ev) {
$("body").on("mouseover", ".author", function (ev) {

c:

// }).live("mouseout", function (ev) {
}).on("mouseout", ".author", function (ev) {

4. zip the files *inside the folder* (don't zip the folder itself).

5. rename the zipped file back to the extension name: "{2a43f346-13de-4aad-adeb-00b61e5bcde3}.xpi"

6. Replace the old extension with the fixed version and everything should work

Useful, but needs some attention from the developer Noté 5 sur 5 étoiles

Midnight_Coder beat me to it. Suddenly javascript alert every page load. jQuery version update on reddit, I imagine.

I use RES and this, because I like the way this does what it does better than the way RES does it, but I need the rest of RES too.

No way to directly contact the dev, by the way? Tsk, tsk.

EDIT: following stfs's advice, I made it work again too, but I ended up just disabling the extension and installing the contained script as a regular Greasemonkey script. Link for the lazy here: http://redd.it/2693yn

Worked great until today Noté 5 sur 5 étoiles

Needs an update, as of today it throws the following error on every page. The error is in an alert that must be dismissed, after which the page functions normally.

Error: $(...).live is not a function

Thanks for this addon. I much prefer it to others as it has only the features I want, without all the bloat of RES.

Great add-on! Noté 5 sur 5 étoiles

This is a fantastic add-on. If one needs a little bit more than the vanilla reddit experience, this on will significantly reduces the need to click around to reveal essential info about other users. If RES is too much for your needs, this one will do the trick.

Admirable. Noté 4 sur 5 étoiles

Very good, I like how it shows up votes and down votes for all comments, it's really admirable.

Thanks!

Thanks :)

Noté 5 sur 5 étoiles

Needs an update to support https://pay.reddit.com/ ; otherwise works great

Noté 5 sur 5 étoiles

GOOD

Noté 5 sur 5 étoiles

I can't say enough good things about this add-on, it's really a must have for anyone that spends a significant amount of time on Reddit.

The only reason that I've had to stop using it is that it's not yet available for Firefox 4.0! :'-(

Cette critique est pour une version précédente du module (0.2.1-signed.1-signed). 

Noté 5 sur 5 étoiles

This is a great extension! I used to use a GreaseMonkey script to get this functionality, but it was the only thing I was using GreaseMonkey for. This seems like a much more efficient way to do the job.

Cette critique est pour une version précédente du module (0.2.1-signed.1-signed). 

Noté 5 sur 5 étoiles

works perfectly, useful tool for we at reportthespammers :)

Cette critique est pour une version précédente du module (0.2.1-signed.1-signed). 

Noté 5 sur 5 étoiles

Maybe it steals too much attention, the total up and down votes aren't as important to me really, but I am going to give you five stars anyway.

Cette critique est pour une version précédente du module (0.2.1-signed.1-signed).