Can't Install on Firefox 8.0 Noté 1 sur 5 étoiles

It says that it's compatible with firefox 8.0 but when I try to install it it says it's not compatible with Firefox 8.0 what the heck?

Cette critique est pour une version précédente du module (0.9.87.1-signed). 

That is not a ChatZilla problem, it's a Firefox/addons.mozilla.org problem! In this case, addons.mozilla.org has been having uptime issues the past two days and this can prevent Firefox getting the compatibility information correctly.