Noté 4 sur 5 étoiles

Version 1.4.1 marked as Firefox 3.0.* compatible but still get incompatible message when try to install it in Firefox 3.0.4.

Cette critique est pour une version précédente du module (1.4.1).