azurewelkin

About me

Developer Information
Name azurewelkin
User since July 5, 2012
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

Correct Identity

Resolution of the compatibility problem with Thunderbird v13 Rated 5 out of 5 stars

I have been experiencing the same problem as avfan (see the review below this one) ever since upgrading to Thunderbird v13. In short Correct Identity seems to always choose the same identity for some of us.

I found the culprit to be Thunderbird v13 including the "Delivery-To" address in the recipient list passed to Correct Identity. For those of us who forward all our emails to one account, this causes Correct Identity to choose this account every time (if it is ordered before the other identities, which is usually the case).

Instead of waiting for the author to update this fantastic add-on, I got impatient and tweaked the code a little bit. I have put the new xpi file and the explanations at the following page:

http://www.stanford.edu/~xidong/correctidentity/

I thought this might be helpful for other people looking for the reason and fix of the same failure, before the next update of Correct Identity addresses it. Thanks for maintaining such a terrific add-on though!

[Reply to the Developer on 07/11/2012:]
I thought choosing the first address in the recipient list that matches any of the identities was nicer, because if you receive an email addressed to one of your identity, but also CC'ed to your other identity, this fix would choose the one that the email is actually addressed to. Your current code selects the first identity (in the order that Thunderbird has on file) that matches any of the recipients, regardless of whether they are in the CC list or not.

This is perhaps a personal preference (albeit a lot of people, if not most, would perhaps prefer choosing the To address over the CC ones). If you could put a simple radio box to let the user choose the way that this is handled, that would be great.

This review is for a previous version of the add-on (1.3.4).