Would certainly be good, but Rated 3 out of 5 stars

It is not compatible with Firefox 17.0.1
Please update would be great.

Thanks