Working now with Mac FF8 Rated 5 out of 5 stars

I've been using DictionarySearch for years and rely on so much that if it had remained incompatible in FF8, I would've stayed with the insecure FF 7.0.1. Unfortunately, even after incrementing the maxVersion from 7.* to 8.* in its install.rdf, Mac FF8 still would not declare DictionarySearch compatible. Thanks to Steven's suggestion on 11/14/11 (below), I added Mozilla's Add-on Compatibility Reporter extension, followed its procedure for testing and deeming extensions compatible, and DictionarySearch is now functional once again. Whew!

This review is for a previous version of the add-on (7.0.0).