Is this compatible with Firefox 14.0.1? Rated 4 out of 5 stars

Dear Mark,

Firefox (14.0.1) is saying the Dictionary is incompatible with this version of Firefox.
Would you be so kind as to let as to let my know if it will become compatible please?

Best Regards.