Cant install on FF4 Rated 1 out of 5 stars

FF Addons reports i have ver3.5.1 and requires 3.6. Actually I have 4.0.1 the most recent. Why cant I install this? I should also mention that I can hover over and preview just fine, it just refuses to download.