Edited: Found out the problem... not on your end Rated 5 out of 5 stars

Not what it used to be. When I first installed this several months ago almost every video I came across on Youtube worked with it in HTML5. It was rare that one didn't. Now about 30% of the videos won't play, and the figure gets lower with each passing day (literally)... as I find some that worked just the day before no longer working the next day.

It must be time for an update or something. Either that and/or Youtube is changing things to make this addon no longer function. 5 months ago I would have given this 5 stars.

I use NoScript as well and have to click (the icon) to play in the upper left corner of the video box. But I had it the same way back when your addon worked just fine too. But just wanted to mention it just the same in case there's a connection.

Edit: I want to keep the original post for a point of reference. I ironically left myself a clue at the end. It has to do with NoScript. I now have to allow a script I never had to before for most videos to play. In the "Blocked Objects" drop down box, for "googlevideo". I have to allow that now and can no longer click to play each video. Youtube must have changed something to make it this way.

Your addon is perfect... I retract my previous comments. Please accept my apology and my thanks for your wonderful addon.

This review is for a previous version of the add-on (2.1.1.1-signed). 

Thanks for your review.
I did not notice any changes in the past days and have not received any bug reports apart from yours.
It would be very nice if you could send me an email with some example-videos that do not work anymore and some information about your system (firefox version, other addons, os), so that I can try to reproduce your problem.

Edit: No Problem, I am glad that it now works for you. :-)