3.6 gets slowed down majorly. Rated 2 out of 5 stars

Have been using it for many years and one of the indispensable add on. But Firefox 3.6.x gets really slowed down by it. I have tried tweaking it, and uninstalling other add-ons . But nothing helps. If you want to use it use FF3.5 or below.

This review is for a previous version of the add-on (0.3.8.2).