trouble with shooter Rated 5 out of 5 stars

it seems it's not working anymore in Firefox 29

This review is for a previous version of the add-on (1.3.3.1-signed). 

Fixed

We just released version 1.3.4 which will make Picozu Shooter compatible with Firefox 29. Thank you for using Picozu!