PrivacySuite. The best, please make it compatable with current and future Fire Fox. Rated 5 out of 5 stars

This was the very best add on, I loved it! then they made it better...NOT with MASK me, and now that is discontinued for an even "better", NOT EVEN called Do not track me, what a pain to use. Please go back to PrivacySuite. At least update it so it works with the current and future Fire Fox. Please?

Mobile App Rated 5 out of 5 stars

Please, Please, Please develop an Android app of PrivacySuite! Hopefully some other people will chime in and ask as well. This addon is one of my absolute favorites on PC. Couldn't live without it..;) Oh, by the way, PrivacySuite is incompatible with FF 33.0.2. Thanks!

This user has 2 previous reviews of this add-on.

Thanks Pablo Rated 5 out of 5 stars

Nice beta fix!
Just locate the "install.rdf" file as instructed by Pablo's post. Open with wordpad and edit the line:

<em:maxVersion>29

Change it to:

<em:maxVersion>999


You may want to save an original copy before editing.

Thanks, Pablo!

Beta fix works! Rated 4 out of 5 stars

To the reviewer who posted the Beta Fix, THANK YOU!

I also have to agree that responses to updating this extension have always been quite slow. Over time, I have been known to not update my FF just to be able to keep this extension working.

The Beta Fix is a Godsend - Thank you!

Beta Fix for PrivacySuite 0.756 for FireFox v30+ Rated 3 out of 5 stars

I love this Addon for its "Website Login Capabilities Only"

I can never remember all the logins and passwords that I create.

Full Information on this Beta Fix "PrivacySuite 0.756 Beta 1" can be found at the following link

http://pastebin.com/MnLXbNmW

(You can open and edit .xpi files with winrar but you must Copy the file to your Desktop before editing)

To the Abine Team I say Please set this Addon to be Compatible to FF v999.*

Your response to compatibility requests are terrible... Update the Addon... Thank you

PS...
Download install.rdf file here: http://rghost.net/56644954
5* Website Login Addon when Compatible with FF v30+ (Let me know if this helps anyone)

Privacy Suite Not Compaitble With FF 30 Rated 3 out of 5 stars

Same issue as Cherokee posted on June 23, 2014. If anyone solves the problem, please post it here!

My rating would otherwise have been 4 star!

Another abandoned project from Abine? Rated 1 out of 5 stars

I enjoyed using the product for some time, but now find I can no longer block masked emails created with PrivacySuite. PrivacySuite also no longer shows up in Abine's product list. Now they have MaskMe for this function. While MaseMe will import your passwords from from PriacySuite, it will not import your masked emails, so it appears we've lost all control of old masked email addresses. Flying wonderful!

This is the second time, that I am aware of, where Abine apparently has abandoned a product, providing no notification to users, or method of cleaning up the wreckage they've left behind.

While I understand that these products are free, with primium options, and therefore may be found unprofitable; I think I may be about done with ABINE. Though I tend to like their products, abandonment seems to create issues with excessive risks, or at least intolerable irritants.

This review is for a previous version of the add-on (0.753). 

FireFox 24 compatability? ... part 2 Rated 3 out of 5 stars

I have enjoyed using this product for a while but the repeating issues with firefox updates is infuriating!
In response to the develpers last answer to this question, since I didn't want to wait to access my banking/phone/cable etc., information;
from(by Abine, Inc., the online privacy company (Developer) on September 19, 2013 ),
"...2), in MaskMe, go under 'Settings' and scroll down; 3), you'll see an option to import your data from Privacy Suite, so just follow the steps on screen :)"

Well, after my investigation, it seems that since privacysuite is disabled at the time, the "settings" page does not detect it as being installed so it doesn't provide the option. At least, that seems to be what was happening in my case. I tried refreshing the page and restarting firefox and still, no option on the settings page. So I downloaded the setup for firefox 23.0.1 from a page that didn't redirect to mozilla, installed, found the privacysuite icon missing, though it is still installed and enabled, and the maskme icon is in it's place.
I added the privacysuite icon back, went to the maskme settings page and viola! The option to import was there.
Basically, your answer didn't/doesn't work.
Next question, when are you approximating an update for firefox 24 support?
It's been over a week, hasn't it?
Does all of your software have these update issues with firefox?

This review is for a previous version of the add-on (0.753). 

Firefox 24 compatible file

Hey there-

We have a version of PrivacySuite that's compatible with Firefox 24, but it always takes some time for it to be posted on the add-ons site. You can get it directly at this link: https://addons.mozilla.org/firefox/downloads/file/228487/privacysuite-0.754-fx.xpi

Thanks!

-The Abine Team

FireFox 24 compatability? Rated 3 out of 5 stars

I love this program will it be updated to run on FireFox 24?The password organizer is invaluable.

This import option is not there for me on the settings page.

This review is for a previous version of the add-on (0.753). 

Your question

Hey there and glad to hear you find our products invaluable. We're working on it, but in the mean time I'd urge you to check out MaskMe, which is the new and much-improved privacy tool we launched that has all of PrivacySuite's features. You can export all of your PrivacySuite data into MaskMe by following these steps: 1), download MaskMe (it's in the Firefox add-ons store, or you can get it from www.abine.com/maskme); 2), in MaskMe, go under 'Settings' and scroll down; 3), you'll see an option to import your data from Privacy Suite, so just follow the steps on screen :)

Thanks, and let us know if you have any questions.

-The Abine Team

Rated 4 out of 5 stars

Anyone having trouble with Privacy Suite not working, it may be due to a conflicting Add on. Fastest Fox will leave the Privacy Suite interface unresponsive. You will be able to sign in to websites using the master password but the gui will not work

This review is for a previous version of the add-on (0.753). 

Cool! Rated 5 out of 5 stars

Thank you for making this such a worthy adds-on, I have no problem with my Firefox 19.0.2
Please make it compatible with DoNotTrackMe adds-on, so these 2 useful adds-on can collaborate together in Firefox browser without have to disable one of this adds-on.

This review is for a previous version of the add-on (0.751). 

Where to start? Amazing! Rated 5 out of 5 stars

It's so easy to just click on the logins and forms button to login and fill out forms- no more keeping a record of all the different logins. For form filling you can set different types, it also generates an anonymous one which links to the mail address of your choice, I like this option for petitions. If you fill out a form differently, it will ask if you want to update your form. I find it awesome to see how many trackers there are on a website, and Abine even identifies them.
There are so many options, I don't know where to stop so I'll just say: if you are chaotic like me, have a ton of logins (who doesn't these days), or don't like to be used for tracking by sneaky companies, maybe even aren't that much into web privacy -like me- and want something to do this for you and provide you with options you didn't even know existed.. This is it. So easy and effective!
It does take some time to set everything, but once this is done, I think you will be pleased.

I didn't know how much I depend on this add-on, until it was gone. Thanks to fullofwit for taking the effort of posting how to fix it, I am happy once again too.

This review is for a previous version of the add-on (0.750). 

Rated 5 out of 5 stars

love this app. for those having problems with firefox 17.0.1 just check below download now and see: view other versions. the latest update is 0.750. I accessed it by looking via google chrome and pasted it to firefox and now I'm a happy customer once again.

This review is for a previous version of the add-on (0.749). 

update problem with firefox 17 Rated 4 out of 5 stars

love this add on. works pretty well most of the time. same problem as previous posters in firefox 17-everytime i close browser it disables. please fix!

This review is for a previous version of the add-on (0.749). 

Problem? Rated 5 out of 5 stars

I love this Add-On, but I'm having trouble with it on Fx 17.0 & now 17.0.1.Every time I close and reopen the browser, Privacy Suite is disabled. The only way to make it work again is to check Add-On updates and then restart Fx. Then it works until I close the browser. The next time I reopen it, Privacy Suite is disabled (as incompatible) again.

Anyone else?

This review is for a previous version of the add-on (0.749). 

Excellent security add-on for FireFox Rated 5 out of 5 stars

One of, if not the best security addons for Firefox. The support is excellent too.

This review is for a previous version of the add-on (0.749). 

Excellent add-on Rated 5 out of 5 stars

This privacy suite is a must for your privacy protection on the web, it works like a charm, lots of features to customize your protection as you like to be.

This review is for a previous version of the add-on (0.748). 

Thank you for updating! Rated 5 out of 5 stars

Very addicted to this excellent add-on. Thanks for updating and calming my online nerves!

This review is for a previous version of the add-on (0.748). 

Best Addon ever Rated 5 out of 5 stars

Thanks for updating. Surfing feels much safer :) Keep it up!

This review is for a previous version of the add-on (0.748).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

I love this addon, but I'm in the same boat as everyone else. I'd love to find out how to access my logins whenever this happens, as it seems to happen every time Firefox is updated. Very inconvenient, these little "gaps" between updates.

This review is for a previous version of the add-on (0.747).