Not working with FF 29 Rated 3 out of 5 stars

Firefox 29 seems to have broken this extension.

This review is for a previous version of the add-on (1.5.8.1-signed.1-signed).