PS muddled/confusing interface/configuration Rated 2 out of 5 stars

FIREFOX: it's not clear to me, how to continue thread at this site, so i wrote a new review, but please treat it as a continuation of the prior thread, with the same title, earlier today

abine my review lacked specifics

i will add donottrackme again later, soon, and set out the concerns i had in detail

that is the correct and fair thing to do

in passing, i am using ff 26.0 and was using the latest version of DoNotTrackMe

i just searched ff add-ons for it to find the version number
ff responded,
"could not find any matching add-ons"

anyhow it was the latest
a version 3 etc

i will get back with explicit detail


This review is for a previous version of the add-on (3.1.1030.1-signed).  This user has other reviews of this add-on.