Broken for Firefox 2.0.0.* Rated 3 out of 5 stars

Very good extension, but like other people have mentioned, the latest version(s) are completely broken on Firefox 2.0.0.*, and has been for a while. Why hasn't there been a fix?

This review is for a previous version of the add-on (2.96).