Rated 5 out of 5 stars

Great pass manager

LastPass 4.x is slow and buggy; downgrading to 3.3.4 Rated 1 out of 5 stars

Another sorely disappointed long-term user of LastPass. The new version is slow - it takes ages to display any of the menus. Sometimes the autofill hotkey works; sometimes it doesn't. The 4.x upgrade doesn't seem to add any useful features, so I've downgraded to 3.3.4. [Go to https://addons.mozilla.org/en-gb/firefox/addon/lastpass-password-manager/versions/. Install and restart Firefox. Addons > LastPass > More > Automatic Updates > Off]

4.1.53 What a disappointment! Rated 1 out of 5 stars

I have been a user and staunch supporter of LastPass for many many years. The somewhat primitive GUI LastPass used to have made me smile but appreciate its simplicity and reliability. Not so anymore with 4.1.53. Broken badly! Bugs, bugs everywhere in Firefox 53 + Windows-10. The basic login to LastPass balloon, emanating from the LastPass icon when clicked, is half transparent making it unusable. After blindly logging in, the half transparent balloon persists making it impossible to operate the standard features like "Show Matching Sites" etc. Crazy! Don't you, folks, do any QA before releases? You are letting a good crypto foundation go to trash for lack of an acceptable GUI. What a waste of a good code!
And what's with the auto-fill inconsistency? Some sites work well but others require manual intervention now. And don't blame it on the site. The site has not changed a bit since the days when LastPass worked just fine.

Less and less usable... Rated 1 out of 5 stars

Since Lastpass was taken over by LogMeIn, it becomes worse and worse. Why don't developpers take into account what their users say ? I'm paying premium and I want to have for my money ! Everyone complaining again and again against big letters, bugs and design flaws ! I got more and more trouble using it, probably until I have to switch to another password manager.... What a pain !!!

Why does it takes so long to fix the terrible 4.0 updates???? Rated 1 out of 5 stars

Since 4.0 unusable for me. Makes firefox, especially at banking sites so slow that it drives me crazy.
I downgrade to 3.3.4, but everyday it upgrades automatically. Can I stop that or else I will consider Lastpass to be LasttimeUsed!

Since the 4.0 update very bad design & slow Rated 1 out of 5 stars

Was working like a blas in the past. Now it's slow, design flaws. The small button right above the UI loads for half etc.

Not pleased with this.

примечательно... Rated 4 out of 5 stars

на фоксе 53,0,2 Win7 последняя работает нормально, а на 52,* XP а так же на Light 48 пришлось вернуться на "троечку" и отключить обновление.

Пользоваться стало невозможно Rated 1 out of 5 stars

Пользоваться стало невозможно, всё никак не допилят до работоспособного состояния новые версии.
Старые нормально не работают с новым Firefox.
Уже пожалел что продлил премиум.
Похоже придётся переходить на альтернативы.

Version 4.1 (May 2017) SUX a lot! Rated 1 out of 5 stars

Weird design. Broken features. Very big letters and all other stuff (I'm not blind!).
Today's developers and designers assume everybody needs glasses an use tablets, so icons and buttons are all huge because apparently people can't use their fingers accordingly (I could offer some ideas LastPass developers could do with their fingers, though...).
Anyway, I HATE THIS TYPE OF DESIGN, all I want is a screen with small stuff in it, because when buttons are huge this way most of then don't even show up on screen if you use windowed browsers.
Donwgraded to before-latest version (from March 2017), now I am very happy again.
Why don't at least give the opportunity for the end user to CHOOSE what he wants?
Shame on you, developers/designers... =o(

LassPass broken on Firefox 53.0 Rated 1 out of 5 stars

LassPass is totally broken on Linux Firefox 53.0!!!!!

Muy buena, me funciona bien Rated 5 out of 5 stars

Me funciona muy bien y su generador de contraseñas seguras me encanta.

This user has a previous review of this add-on.

New version sucks !!! Rated 1 out of 5 stars

This New version causing firefox hang and crash. I had to remove it.

Rated 1 out of 5 stars

До сих пор не работает автозаполнение полей, очень разачарован т.к. практически за месяц беспорядков, в положительную сторону не сделано никаких подвижек :(

Возникает проблема Rated 4 out of 5 stars

Добавьте нужную подпись к дополнению (Мозила Файерфокс). Мозила периодически отключает его, т.к. нет этой подписи. А в целом дополнение отличное.

Total CRAP from LogMeIn (Lastpass) Rated 1 out of 5 stars

Lastpass sold it's soul to Logmein and has utterly destroyed an awesome plugin. Been a premium user for 5 years and am really disappointed that this is the direction the company has decided to go.

This user has 5 previous reviews of this add-on.

Что же еще?! / What Else?! Rated 5 out of 5 stars

Самый удобный менеджер паролей, для меня уж точно. Упрощает жизнь вдвойне, а при наличие ПРЕМИУМ и ай-гаджета втройне! Функционал приложения полностью устраивает.
Хотелось бы добавить в раздел "Генератор паролей" возможность генерации на основе парольных фраз!

Works great but... Rated 3 out of 5 stars

It logs in any time anyone brings up firefox on my computer at work no matter what options I pick.

Totally dead weight Rated 1 out of 5 stars

i have tried so many times to get this to work, but now i give up.
this is really self-destructive from the developer. it's very disappointing.
I know that this is used by a lot of people - it actually is one of the few add-ons that actually made browsing a lot faster and easier. but not anymore. i need a replacement asap. anyone got any suggestions?

LastPass not verified Rated 1 out of 5 stars

LastPass 4.1.53 installed from AMO still gives me the message: "LastPass: Free Password Manager could not be verified for use in Firefox and has been disabled."

This has been occurring since last year. I can not find any setting to fix this. This also occurs in CLIQZ, a modified version of Firefox. LastPass works just fine in every other browser I have tried. At this point I don't think LastPass is to blame. The following add-ons are or will soon be inoperable:

CleanLinks
Beyond Australis
OmniSidebar
Self-Destructing Cookies
Classic Theme Restorer

Other than being open-sourced, extensions like these are the main difference between Mozilla and the chromium browsers, and at least add-ons from the Chrome store will load. I've been using Firefox since '03 because it didn't have IE's security issues and had a lot of customization ability due to these extensions. Now a mainstream add-on like LastPass is inoperable. At this point, the only feature that Firefox has that others don't is NoScript and TOR which are only relevant to niche users. I'm not getting the vibe from Mozilla that this will be remedied anytime soon.

This user has a previous review of this add-on.

Last Pass V4 Rated 1 out of 5 stars

How to ruin a great product? Do what Last Pass did, issue a new version and make it unusable in Firefox. Nothing worked correctly. Reloaded version 3 now up and running in 3 mins flat after 10 days of messing about. If Last Pass had not been so good in the past. I would have ditched it. I doubt I will renew my subscription and will revert to free version.

This review is for a previous version of the add-on (4.1.49).