Not working with FF 12 Rated 1 out of 5 stars

Well,I just installed it,and found it in the disabled section of my extensions,where it is labelled not compatible with FF 12..
Badly in need of an update..