It works even with FF 13 Rated 5 out of 5 stars

You can make any add-on being accepted by FF easily . Go into about:config and add for your FF version (mine is 13.0) the entry

extensions.checkCompatibility.13.0

This is a boolean value. Set it to false.

If you upgrade to a higher FF version just add another entry with the new version information.

For me the Line Marker is a great add-on. I use it with the great add-on UnMHT where you can save webpages or a selection out of it in the compressed mht form. The marked text will be saved as marked with it.

This user has a previous review of this add-on.