MAKE COMPATIBLE PLEASE!! Rated 5 out of 5 stars

***PLEASE MAKE THIS COMPATIBLE WITH FIREFOX 4!!! Am dying here without this or Yooper!!