please make autoauth compatible with FF5 Rated 5 out of 5 stars

Hi,
I find this very useful and using this from couple of years. yesterday i have upgraded to FF5 & found this addon is not compatible.
please make this work with FF5.

Rajeev