AMO is getting a new look. Would you like to see it?

Visit the new site

Close

Armenian (hy-AM) Language Pack Version History

43 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 57.0 519.1 KiB Works with Firefox 57.0 - 57.*

Version 56.0 536.1 KiB Works with Firefox 56.0 - 56.*

Version 55.0 528.8 KiB Works with Firefox 55.0 - 55.*

Version 54.0 503.9 KiB Works with Firefox 54.0 - 54.*

Version 53.0 508.9 KiB Works with Firefox 53.0 - 53.*

Version 52.0 504.0 KiB Works with Firefox 52.0 - 52.*

Version 51.0 498.3 KiB Works with Firefox 51.0 - 51.*

Version 50.0 501.8 KiB Works with Firefox 50.0 - 50.*

Version 49.0 505.1 KiB Works with Firefox 49.0 - 49.*

Version 48.0 511.0 KiB Works with Firefox 48.0 - 48.*

Version 47.0 503.5 KiB Works with Firefox 47.0 - 47.*

Version 46.0 508.6 KiB Works with Firefox 46.0 - 46.*

Version 45.0 482.5 KiB Works with Firefox 45.0 - 45.*

Version 44.0 536.5 KiB Works with Firefox 44.0 - 44.*

Version 43.0 535.9 KiB Works with Firefox 43.0 - 43.*

Version 42.0 531.6 KiB Works with Firefox 42.0 - 42.*

Version 41.0 525.7 KiB Works with Firefox 41.0 - 41.*

Version 40.0 562.0 KiB Works with Firefox 40.0 - 40.*

Version 39.0 550.0 KiB Works with Firefox 39.0 - 39.*

Version 38.0.5 546.4 KiB

Version 38.0 546.1 KiB Works with Firefox 38.0 - 38.*

Version 37.0 538.9 KiB Works with Firefox 37.0 - 37.*

Version 36.0 534.0 KiB Works with Firefox 36.0 - 36.*

Version 35.0 530.1 KiB Works with Firefox 35.0 - 35.*

Version 34.0 525.1 KiB Works with Firefox 34.0 - 34.*

Version 33.1 511.2 KiB Works with Firefox 33.1 - 33.*

Version 33.0 501.5 KiB Works with Firefox 33.0 - 33.*

Version 32.0 493.8 KiB Works with Firefox 32.0 - 32.*

Version 31.0 490.9 KiB Works with Firefox 31.0 - 31.*

Version 29.0 432.5 KiB Works with Firefox 29.0 - 29.*