Puntuado con 5 de 5 estrellas

Great theme! , but please update it for Firefox 17.0a1. You said that version 15beta1 is compatible, but i can´t install it.

Esta valoración es de una versión anterior del complemento (13.1).