Puntuado con 5 de 5 estrellas

It's marked as compatible, but it doesn't work with Firefox 8 Nightly. ;)
No problems with Firefox 7 Aurora. :)

Esta valoración es de una versión anterior del complemento (0.1.4).