update firefox 4 Rated 4 out of 5 stars

firefox 4 needed