Rated 4 out of 5 stars

For all Firefox users (Nightly or UX) who were having issues with "Corrupt" bookmarks, and could not sync, for right now, go to xmarks.com and download the newest update, Version 4.1.0, and it should resolve your issue, as I have just tried this update with 100% success. I am able to sync my bookmarks once again, with no error message. Thank you Xmarks!!

This review is for a previous version of the add-on (4.0.6.1-signed).