Rated 5 out of 5 stars

NEED Update for Firefox 3.6! Please.

Bitte für Firefox 3.6 updaten. Danke.

This review is for a previous version of the add-on (3.6.5).