dosnt work Rated 1 out of 5 stars

Torrent Finder Toolbar 1.2.4 could not be installed because it is not compatible with Firefox 3.5.3. CAN SOMEBODY HELP ME ON THIS ??? PLS. when i download an older version of firefox it works untill its updating....

This review is for a previous version of the add-on (1.2.5).