Rated 4 out of 5 stars

up until 3.5 this really worked.
I have been teaching myself Ukrainian (Russian) and I found it very useful.
I've been waiting for your update so that I can use it in my beta installs (currently 3.6b6), but ... In the 'installed' version of firefox (3.5 in openSuSE 11.2 - KDE 4.3.4) it looks like it works, but it does not change anything. The menu indicates that I have selected Russian or Ukrainian, but my menus and dialogs are in English... I have no problem using downloaded versions of either RU or UA firefox (Namarok), but sometimes i need all the 'natively installed' bits to the OS' version of FF... blah, blah, blah..
Landis.

This review is for a previous version of the add-on (2.1).