Rated 1 out of 5 stars

Will not work on the newest version of FF. ggrrr...

This review is for a previous version of the add-on (1.5.20090525).