Does Not Work in FF 17.0 Rated 1 out of 5 stars

This addon needs to be updated. It does not work with FF 17.0. When you switch to the IE engine the page fails to load. You can not navigate to any page at all.

This review is for a previous version of the add-on (4.1.3.1).