Not working in FF 17beta Rated 1 out of 5 stars

Needs updating. I can't find ANY addons to view in IE. Some websites simply don't fully load or have working links in FF, so IE is required.

This review is for a previous version of the add-on (4.1.3.1).