100% compatible with Firefox 4 Rated 5 out of 5 stars

It still works perfectly under Firefox 4. The only shortcoming is that it's not being updated, so you have to set extensions.checkCompatibility.4.0 and extensions.checkUpdateSecurity variables to false in about:config.