Rated 5 out of 5 stars

"Not compatible for 3.6 or 3.7"? What you talking about willis? The current version is 3.5.3 It works just fine.