Here's howto get this working in any FF version Rated 5 out of 5 stars

First of all, PLEASE update this extension! It's great and superuseful.

Otherwise here's how you get this working. Download an addon/extension here called "Nightly Tester Tools" - after its installed, type in your URL bar about:config; then in the search box look for a key called "nightly.disablecheckcompatibility" right click it and set the value to True. Then restart. Now come back to the DP extension and then install away!