Great extension Rated 5 out of 5 stars

If you want to use it with Firefox 4 just type about:config on the address bar, right click on any item and add a boolean value called extensions.checkCompatibility.4.0 setting it to false.