Rated 4 out of 5 stars

Will this version work in ff 3.6.x if I override version checking to install it?