this was a great extension in its day Rated 5 out of 5 stars

Modern adblocking has modeled resource selection on this extension. Ad-hiding can now use BOTH

CSS selectors
and
XPath

FTW

It Work fine With Firefox 49 !!! Rated 5 out of 5 stars

Just edit the RDF File inside the XPI !

Rated 5 out of 5 stars

I miss this plugin so bad

Works on 25.0.1 Rated 5 out of 5 stars

Still fine on 25.0.1 but tested it on 23.0 too! (See "sammingo" and "yk2000" comments for details about the install steps.)

Rated 1 out of 5 stars

Can anyone make it available for Firefox 17.0...?

How does RegExp works in here? Rated 2 out of 5 stars

Cannot figure out how does RegExp works in here. It is shown in 'Content Extraction' clip yet i fail to evaluate regex i enter.

This user has a previous review of this add-on.

Rated 5 out of 5 stars

Tested on Firefox 14.0.1 and works ok.
Need some work to install, but it pays off. Best tool for xpath / xquery related jobs

See "sammingo" and "yk2000" comments for details about the install steps.

This user has 2 previous reviews of this add-on.

Rated 1 out of 5 stars

it is not compatible with firefox 13.0.1

Works with FF 13 too! Rated 5 out of 5 stars

Works on Firefox 13 on modifying the install.rdf file as mentioned by sammingo and yk2000. For me, it is the best and simplest xpath tool ever!

Still works in FF11 Rated 4 out of 5 stars

I can confirm that yk2000's instructions still work in FF 11. (See comments below.) At first, I got the same error as NottyWizard, but then I realized that my ZIP program changed the directory structure. Compare it to the original and make sure they are the same.

You also need the "DOM Inspector" addon to make this work. See the screenshots for help getting started with Xpather.

I only gave it 4 stars because it was such a hassle to install.

The XPath addon for Firefox Rated 5 out of 5 stars

Please update it! Your addon is too useful.
Thanks.

Rated 3 out of 5 stars

Thanks sammingo and yk2000. I tried your method but FF keeps saying "the add-on is corrupt". Any help? I'm using FF 10.0.2

Addition to sammingo's explaination Rated 5 out of 5 stars

1. Right click on "Add to Firefox" link and do a "save link". This will create a .xpi file at selected location.
2. Use 7zip or any other unzipping tool and extract the content.
3. Edit the .rdf file as sammingo mentioned.
4. Zip the content back to a zip file and rename it to .xpi (remember to keep the original package structure)
* Alternatively just extract .rdf file, edit it and add back to the .xpi file

Rated 4 out of 5 stars

If you change the install.rdf file's line to something like this:
<em:maxVersion>9.*</em:maxVersion>

and then restart firefox, this plugin still works fine.

Where is version for firefox 5? Rated 5 out of 5 stars

Where is version for firefox 5?

Updated for 4.* Rated 5 out of 5 stars

Great add-on. It's a shame it has been abandoned by the developer. I have uploaded a patched version of the addon to my server that will allow installation on 4.* If you want it, you can get it here: http://jassage.com/xpather-1.4.5b.xpi

Rated 5 out of 5 stars

I did the same trick for FF4.* (changed maxVersion to 4.*) Regarding Windows, that folder was already empty .

xpather worked for 3.6 Rated 5 out of 5 stars

Thanx muc mac.. it worked :) for Windows.

This review is for a previous version of the add-on (1.4.3). 

Rated 5 out of 5 stars

As LijuC pointed out, on windows systems it's not enough to only change maxVersion tag. Also extension.cache file located in [user]\Application Data\Mozilla\Firefox\Profiles\[some-hash].default\ must be deleted(personally i would make backup first, just in case), to force firefox to reread version information and update status of extension compatibility.

This review is for a previous version of the add-on (1.4.3). 

not working for 3.6 Rated 1 out of 5 stars

@muc mac
I made my changes in the install.rdf with:
maxVersion to 3.6.*

but still the Firefox is not enabling the XPather. anything else i need to do.

Windows Directory: "[user]\Application Data\Mozilla\Firefox\Profiles\b8k8sy2b.default\extensions\{636fd8b0-ce2b-4e00-b812-2afbe77ee899}"

Thanx

This review is for a previous version of the add-on (1.4.3).