not compatible with Firefox 3.6.20 Rated 3 out of 5 stars

I am currently running 0.7.1. When I try to install the latest update for Less Spam to Firefox 3.6.20, I get the message:

Less Spam, please 0.7.2 could not be installed because it is not compatible with Firefox 3.6.20.

This review is for a previous version of the add-on (0.7.2).