AMO is getting a new look. Would you like to see it?

Visit the new site

Close

NewTabURL Version History

22 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 2.2.3.1-signed.1-signed 57.6 KiB Works with Firefox 1.5 - 56.*

Fixed clipboard security issue.

Version 2.2.2.1-signed.1-signed 55.5 KiB Works with Firefox 1.5 - 7.*

Fixed location bar selection issue on Firefox 4.0.*.

Version 2.2.0.1-signed.1-signed 53.2 KiB Works with Firefox 1.5 - 4.0.*

Added option to always keep a new tab open.

Version 2.1.0 45.0 KiB Works with Firefox 1.5 - 3.6.*

Version 1.6.2 45.0 KiB Works with Firefox 1.5 - 3.6.*

Fixed issues of some users using Firefox 3.5.

Version 1.6.1 45.0 KiB Works with Firefox 1.5 - 3.5.*

- Released under GPLv3.
- Added Firefox 3.5 compatibility.

Version 1.6.0 28.0 KiB Works with Firefox 1.5 - 3.1b2

Fixed Firefox 3.0 issues.

Version 1.5.4 28.0 KiB Works with Firefox 1.5 - 3.0.*

Added Firefox 3.0 compatibility.

Version 1.5.2 30.0 KiB Works with Firefox 1.5 - 2.0.0.*

- Fixed version 1.5.1 error with some users.
- Added an option to choose if the url bar must be selected when the page in the new tab is loaded.
- Fixed error when loading the options window.

Version 1.5.1 29.0 KiB Works with Firefox 1.5 - 2.0.0.*

Added new localizations.

When the page in the new tab is loaded, the current url in the url bar is selected.

Version 1.4.3 17.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.3.2 15.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.2.6 12.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.2.2 7.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.2.0 7.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.1.4 7.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.1.3 6.0 KiB Works with Firefox 1.5 - 1.5.0.*

Version 1.1.2 6.0 KiB Works with Firefox 1.5 - 1.5.0.*

Version 1.1.1 5.0 KiB Works with Firefox 1.5 - 1.5.0.*

Version 1.1 5.0 KiB Works with Firefox 1.5 - 1.5.0.*

Version 1.0.2 5.0 KiB Works with Firefox 1.5 - 1.5.0.*

Version 1.0 4.0 KiB Works with Firefox 1.5 - 1.5.0.*