Very good extension Rated 5 out of 5 stars

Very like to use this extension. Please, update it for FF 3.6.x compatibility, i'm wait for it. :)
Thanks.

This review is for a previous version of the add-on (0.15).