Well done, made it worse. Rated 1 out of 5 stars

2.5.3 has now been broken for months on firefox 3.6.28 (and don't tell me to upgrade Firefox, *you* broke something that worked, not me.) so I can't use it at all. So after making it worse to use in v2.5, you now made it *impossible* to use. I don't miss it either.

This review is for a previous version of the add-on (2.5.3).  This user has a previous review of this add-on.

Thanks for your valuable feedback.

We strongly suggest that you upgrade to the latest version of Firefox as versions 3.X will no longer be supported shortly.

Kind Regards.